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Bài 2

Giới thiệu về Sketch
Các nội dung chính trong bài học này:

· Tạo một bản vẽ mới

· Chèn một Sketch mới cho mô hình.

· Thêm một đối tượng vào Sketch

· Thiết lập các mối quan hệ giữa các đối tượng trong Sketch

· Các trạng thái khác nhau của các đối tượng trong Sketch.

· Sử dụng công cụ trên thanh  Sketch để tạo vát góc và góc lượn.

· Extrude biên dạng trong mặt phẳng Sketch thành solid
2D Sketching
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Bài này giới thiệu về 2D Sketch, nền tảng của mô hình 3D trong phần mềm SolidWorks.

Sketch được sử dụng cho tất cả các đặc điểm trong SW, nó bao gồm

Extrusions

- Revolves

- Sweeps

- Lofts

Hình 2.2 minh hoạ: Việc tác động của các lệnh 3D lên cùng một  Sketch để tạo nhiều đặc điểm khác nhau:
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Trong bài này chúng ta chủ yếu sử tạo đặc điểm Extrude, các đặc điểm khác sẽ được trình bày ở các bài tiếp theo

Các  bước để tạo một đặc điểm
Mọi Sketch đều có nhiều tính chất khác nhau, nó bao gồm hình dạng, kích cỡ và hướng.

- New Part (tạo một chi tiết mới)
Chi tiết có thể được tạo với đơn vị đo là inch, millimeter hoặc các đơn vị khác

- Sketch (mặt phẳng vẽ phác)
Sketch là tập hợp các đối tượng 2D, chúng được sử dụng để tạo các đặc điểm solid.

- Sketch Geometry (đối tượng vẽ phác)
Thuộc kiểu hình học 2D như đường thẳng (line), đường tròn (circle), hình chữ nhật (rectangle).

- Sketch Relations (quan hệ giữa các đối tượng trong Sketch)
Các quan hệ hình học như: Đường thẳng theo phương ngang, dọc được áp đặt cho các đối tượng 2D. Những quan hệ đó sẽ hạn chế việc di chuyển của các đối tượng

- State of the Sketch (trạng thái của Sketch)
Một Sketch có các trạng thái cơ bản sau đây: fully difine (đầy đủ) có màu đen, under define (thiếu) có màu xanh hoặc over difine (quá định nghĩa) có màu đỏ.

- Sketch Tools (thanh công cụ Sketch Tools)
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Các lệnh trên thanh  Sketch Tools được sử dụng để tạo hoặc  hiệu chỉnh các đối tượng Sketch, chúng thường bao gồm các công cụ cắt (trim), kéo dài (extension) các đối tượng.

- Extruding the Sketch (Kéo Sketch)
Extruding được sử dụng để kéo 2D Sketch để tạo đặc điểm 3D Solid.
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Sketch Contour
Với công cụ này bạn có thể chọn một vùng của Sketch để tạo đặc điểm.

Các bước thực hiện trong bài này bài gồm tạo Sketch và  sử dụng lệnh Extrude.

Tạo chi tiết như hình 2.1
1. Tạo bản vẽ mới

Kích [image: image90.png][+ @O/ OXKL d¥ T




, hoặc kích File, New hộp thoại New SolidWorks Document xuất hiện, chọn tab Tutorial, chọn bản vẽ Part, và kích OK.
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2. Lưu bản vẽ

Chọn File > Save hoặc kích [image: image2.png]


 trên thanh công cụ Standard, hộp thoại Save as xuất hiện (hình 2.4).  Nhập tên bản vẽ cần lưu trữ “Plate” vào hộp File name và chọn phần mở rộng của bản vẽ là *.sldprt. Kích Save lưu bản vẽ.
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3. [image: image24.png]


Chọn mặt phẳng để mở mặt phẳng vẽ phác

Trên cây FeatureManager, chọn mặt phẳng Front, mặt phẳng được chọn sẽ sáng lên trong vùng đồ hoạ (hình 2.5)
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4.  Mở mặt phẳng vẽ phác

 Mở mặt phẳng vẽ phác bằng cách kích [image: image3.png]


 trên thanh công cụ Sketch, hoặc chọn Sketch từ menu Insert.

Chú ý: Gốc toạ độ trong mặt phẳng vẽ phác sẽ có màu đỏ, biểu thị mặt phẳng vẽ phác đã được kích hoạt.
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Khi mặt phẳng vẽ phác được kích hoạt thì xuât hiện một biểu tượng phía trên góc phải của vùng đồ hoạ. Một biểu tượng giống biểu tượng của lệnh Sketch, biểu tượng còn lại có hình dạng X màu đỏ. Biểu tượng này cho ta biết mặt phẳng vẽ phác đang được kích hoạt. Nếu ta kích vào biểu tượng Sketch thì  ta sẽ thoát khỏi mặt phẳng vẽ phác và sẽ lưu lại các thông tin mà ta đã thực hiện trên đó. Ngược lại nếu ta kích vào biểu tượng màu đỏ thì ta sẽ thoát khỏi mặt phẳng vẽ phác và các thông tin ta thực hiện trên đó không được lưu lại.
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SolidWorks cung cấp nhiều công cụ tạo các đối tượng Sketch khác nhau để tạo các biên dạng hình học, bài này giới thiệu 3 công cụ cơ bản: Lines, Circles, và Rectangles.

Bảng dưới thống kê một số công cụ trên thanh Sketch Tools.

	Sketch Entity
	Toolbar Button
	Geometry Example

	Line
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	Circle
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	Centeroint Arc
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	Tangent Arc
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	3 Point Arc
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	Ellipse
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	Spline
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	Rectangle
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	Point
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Các thao tác cơ bản cho các đối tượng trong Sketch 2D: Sử dụng công cụ Line tạo đường thẳng

Thao tác chuột

Trong thao tác đối với chuột có 2 thao tác cơ bản: Click-Click và Click – Drag:

Chú ý các biểu tượng phản hồi lại khi tạo đường thẳng:”V”,”H”…

Kích hoạt công cụ Line

· Từ menu Tools chọn Sketch Entity, Line

· Trên màn hình đồ hoạ , kích chuột phải và chọn Line từ menu ngữ cảnh.

· [image: image49.png]


Hoặc chọn [image: image4.png]


 trên thanh công cụ Sketch Tools.
5. Tạo đường thẳng

[image: image50.png]


Kích lệnh Line  trên thanh công cụ Sketch Tools tạo đường thẳng theo phương ngang (hozisontal) đi qua gốc toạ độ. Biểu tượng “H” xuất hiện tại vị trí con trỏ, chỉ rõ rằng mối quan hệ theo phương ngang sẽ tự động cập nhật cho đường thẳng. Số chỉ độ dài của đường thẳng đang được tạo 
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6. Tạo đường thẳng tiếp theo

Tại điểm cuối của đường thẳng vừa vẽ, tạo một đường thẳng mới  (hình 2.8).
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Tự động tạo các mối quan hệ

Các biểu tượng “H”, “V” và các đường thẳng chấm gạch sẽ xuất hiện để giúp bạn thấy được các mối quan hệ có thể được tạo với các đối tượng đã có trên mặt phẳng vẽ phác như: vuông góc, theo phương ngang, dọc, tiếp xúc và đồng tâm.

Trên hình 2.9 các đường 

dẫn hướng  xuất hiện A và B.

A là dẫn hướng vuông góc và thẳng góc, B là dẫn hướng theo phương dọc với đường thẳng đã có.
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7. Tạo đường thẳng vuông góc với đường thẳng vừa vẽ

Di chuyển chuột theo phương vuông góc với đường thẳng vừa được vẽ, khi đó đường thẳng dẫn hướng xuất hiện. Quan hệ vuông góc được tạo giữa đường thẳng đang vẽ và đường thẳng tạo trước đó (hình 2.9).

8. [image: image56.png]


Tiếp tục tạo đường thẳng vuông góc

Tạo đường thẳng vuông góc với đường thẳng vừa vẽ và đi qua điểm cuối của đường thẳng đó. Quan hệ vuông góc sẽ tự động được thiết lập (hình 2.10).

9. [image: image57.png]


Tạo đường thẳng theo phương ngang
Di chuyển chuột theo phương ngang, khi đó các đường thẳng dẫn hướng theo phương thẳng góc và vuông góc cũng xuất hiện, tiếp tục di chuyển chuột theo phươn ngang cho đến khi đường thẳng dẫn hướng theo phương dọc xuất hiện (hình 2.11). Nhấn chuột kết thúc việc tạo đường thẳng. Đường thẳng này có quan hệ theo phương ngang và điểm cuối của đường thẳng này luôn luôn thẳng góc với điểm cuối của đường thẳng đầu tiên.

Công cụ Quick Snaps:

Lựa chọn Quick Snaps được sử dụng trong suốt quá trình tạo các đối tượng trên mặt phẳng Sketch, nó cho phép người dùng lọc một hoặc một số đối tượng nào đó từ nhiều đối tượng khác nhau trên mặt phẳng vẽ phác.
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10. [image: image59.png]vl




Đóng kín Sketch

Di chuyển chuột tới điểm đầu của đường thẳng được tạo đầu tiên. Khi đó trạng thái con trỏ [image: image5.png]


cho ta biết được mối quan hệ concident sẽ được giữa 2 điểm cuối của 2 đường thẳng đó, nếu ta nhấn chuột tại vị trí đó (hình 2.12).

11.   Huỷ bỏ công cụ tạo đường thẳng

Để huỷ bỏ công cụ này, ta có thể thực hiện bằng một số cách sau:

Nhấn Ecs trên bàn phím.

Kích lại công cụ Line [image: image6.bmp]  trên thanh  Sketch Tools.

Kích [image: image7.png]


 trên thanh  Sketch.

Nhấn chuột phải trên màn hình đồ hoạ, và chọn Select từ menu ngữ cảnh.
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Trạng thái của Sketch

Sketch chỉ có thể có một trong 3 trạng thái sau. Các trạng thái của nó phụ thuộc vào quan hệ hình học giữa các đối tượng và các kích thước định nghĩa nó.

Trạng thái định nghĩa chưa đầy đủ (Under Defined): Sketch có màu xanh

Trạng thái định nghĩa đầy đủ (Fully Defined). Sketch có màu đen.
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Trạng thái quá định nghĩa (Over Defined). Sketch có màu đỏ.

12. Xét trạng thái của Sketch vừa được tạo
Sketch vừa được tạo ở trạng thái thiếu định nghĩa. bởi vì có một số  đối tượng trong Sketch có màu xanh (chưa định nghĩa đầy đủ). Chú ý màu của điểm cuối của một đường thẳng có thể có màu khác và trạng thái khác với chính trạng thái của đường thẳng chứa nó. Ví dụ đường thẳng đi qua gốc toạ độ có màu đen, bởi vì đường thẳng đó chịu ràng buộc theo phương dọc và bị cố định một đầu tại gốc toạ độ. Tuy nhiên điểm cuối của đường thẳng đó có màu xanh bởi vì chiều dài của đường thẳng đó chưa được định nghĩa đầy đủ.

· Đối tượng có mầu đỏ: Quá định nghĩa

· Màu xanh: Đối tượng chưa được định nghĩa đầy đủ

· Màu đen: Đối tượng được định nghĩa đầy đủ
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Hiển thị các mối quan hệ có trong bản vẽ

Kích Sketch Relations [image: image8.bmp] trên thanh công cụ Sketch Relations.  Hộp thoại PropertyManager xuất hiện và trong danh danh relations chứa tất cả các mối quan hệ có trong bản vẽ.
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13. [image: image64.png]


Hiển thị các mối quan hệ với một đường thẳng

Kích đúp chuột vào đường thẳng cần tìm các mối quan hệ với nó. Khi đó trên Sketch sẽ xuất hiện các biểu tượng chỉ mối quan hệ giữa đường thẳng được chọn và đường thẳng được biểu tượng chỉ đến. Đồng thời trong danh sách Exis Relations của hộp thoại PropertyManager cũng chứa các mối quan hệ với đối tượng được chọn đó.

14.  Xoá mối quan hệ đã có

Để xoá các mối quan hệ đã có của một đối tượng, nhấn đúp vào đối tượng cần xoá quan hệ. Trong danh sách Exis Relations của hộp thoại PropertyManager xuất hiện các mối quan hệ hiện có của đối tượng đó, chọn mối quan hệ trong danh sách đó và nhấn phím Delete.
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Các mối quan hệ giữa các đối tượng trong SW
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Add Relations (thêm quan hệ) được sử dụng để tạo các mối quan hệ về hình học như song song hoặc trùng nhau giữa các đối tượng trong Sketch.

Kích hoạt công cụ tạo mối quan hệ:

Chọn các đối tượng cần tạo quan hệ, sau đó chọn quan hệ cần thiết lập từ danh dách Add Relations của hộp thoại PropertyManager.

Hoặc kích chuột phải lên đối tượng, và chọn Add Relations từ menu ngữ cảnh.

Hoặc kích [image: image9.bmp] trên thanh công cụ Sketch Tools.

Chọn nhiều đối tượng

Trong bài 1 chúng ta đã học cách chọn một đổi tượng bằng cách nhấn chuột trái trên đối tượng cần chọn. Vây để chọn nhiều đối tượng cùng một lúc, ta giữ phím Ctrl và  nhấn chuột trái lên các đối tượng.
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Ghi kích thước (Dimention)

Các cách khác nhau để ghi kích thước cho các đối tượng trong Sketch.

Từ menu Tools chọn Dimensions, Parallel.

Hoặc kích chuột phải và chọn Dimensions từ menu ngữ cảnh.

Hoặc kích Dimensions [image: image10.bmp] trên thanh công cụ Sketch Tools.

Vị trí ghi kích thước

Tuỳ thuộc vào vị trí ghi kích thước mà ta có các mối quan hệ khác nhau giữa các đối tượng được chọn.

Ví dụ: Chọn 2 điểm cuối của 2 đường thẳng và ghi kích thước về khoảng cách cho 2 điểm đó. Tuỳ theo vị trí của chuột mà kích thước được tạo thuộc một trong 3 khả năng sau:
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14.   Ghi kích thước thẳng cho đối tượng

[image: image73.png]


Kích Dimension   [image: image11.bmp] trên thanh công cụ Sketch Tools, kích chuột chọn đường thẳng cần ghi kích thước, nhấn chuột lần nữa để xác định vị trí cần ghi kích thước. Vị trí ghi kích thước nằm phía trên và bên phải so với đường thẳng. Hộp thoại Modify  xuất hiện chứa giá trị kích thước hiện tại của đường thẳng. Nhập giá kích thước cho đối tượng vào hộp thoại.

Một số nút chức năng trong hộp thoại Modify.
·  Tăng giảm giá trị trong kích thước trong hộp thoại

· Nhập gía trị  kích thước trong hộp thoại  cho đối tượng và thoát khỏi hộp thoại.

· Lấy lại giá gốc và thoát khỏi hộp thoại.

· Xây dựng lại đối tượng với giá trị trong hộp thoại (không thoát khỏi hộp thoại)
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15. Nhập giá trị kích thước

Thay đổi giá trị kích thước trong hộp thoại 40mm  và kích Save [image: image12.bmp] (hình 2.16). 
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16. Ghi  kích thước thẳng cho các đối tượng khác (hình ).
(Hình 2.17)
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Ghi kích thước góc

Để ghi kích thước góc ta vẫn dùng công cụ Dimesion giống như ghi kích thước dài, nhưng đối tượng được chọn để ghi kích thước ở đây là 2 đường thẳng thay vì 2 điểm được chọn như trước.
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17. Ghi kích thước góc 125 độ

Sử dụng công cụ Dimension để tạo kích thước góc cho các đối tượng như hình vẽ bên.

Các đối tượng trong Sketch đã được định nghĩa đầy đủ.

18. Tạo góc lượn 

Kích [image: image13.bmp] trên thanh công cụ Sketch Tools hoặc chọn Tools > Sketch tools > Fillet…

Nhập bán kính fillet: 5 và chọn tất cả các góc của Sketch.
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Kích OK.
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Extrude

Sau khi Sketch đã được tạo hoàn chỉnh, sử dụng công cụ Extrude để tạo thành các đặc điểm cho mô hình.  Có nhiều lựa chọn khác nhau lệnh Extrude, bao gồm điều kiện cuối (end conditions), góc nghiêng (draft) và chiều sâu extrude (depth). Các lựa chọn đó sẽ được thảo luận chi tiết hơn vào các bài sau. Hướng Extrude theo hướng pháp tuyến với mặt phẳng chứa Sketch.

Để kích hoạt lệnh Extrude:

Chọn từ menu: Insert > Boss/Base > Extrude…

Hoặc chọn  [image: image14.bmp]  trên thanh công cụ Features
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19. Sử dụng công cụ Extrude để kéo dài Sketch đã được tạo

Chọn Insert > Boss/Base > Extrude… Hộp thoại Extrude xuất hiện, đồng thời trên vùng đồ hoạ cũng có sự thay đổi
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Hướng mũi tên xuất hiện chỉ cho ta biết chiều Extrude và ta cũng quan sát trước được đặc điểm sẽ được tạo với các giá trị trong hộp thoại Extrude.

Thay đổi các giá trị trong hộp Extrude.

Chọn End Condition = Blind

Nhập [image: image15.bmp] (depth) = 15

Kích OK để tạo đặc điểm.

Đặc điểm Extrude đã được tạo, nó là đặc điểm đầu tiên của mô hình. Sketch để dựng lên đặc điểm này nằm ở mức trong đặc điểm Extrude1 như hình vẽ.
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Edit Sketch (Hiệu chỉnh Sketch)

Sau khi đặc điểm được tạo, ta vãn có thể thay đổi Sketch tạo đặc điểm đó bằng cách sử dụng công cụ Edit Sketch. Khi chế độ hiệu chỉnh Sketch được kích hoạt ta có thể thay đổi giá trị kích thước, hình học và các mối quan hệ về hình học của các đối tượng trong Sketch.

Sau ta hiệu chỉnh Sketch và thoát khỏi Edit Sketch thì mô hình được cập nhật lại theo các thông số mà ta đã thay đổi.

Kích hoạt công cụ Edit Sketch

· Kích chuột phải lên đặc điểm chứa Sketch mà ta muốn hiệu chỉnh, và chọn Edit Sketch từ menu ngữ cảnh. Ta có thể chọn các đặc điểm đó trên vùng đồ hoạ hoặc trên cây FMD.

· Hoặc ta cũng có thể mở rộng đặc điểm chưa Sketch cần hiệu chỉnh và chọn Edit Sketch từ menu ngữ cảnh.

[image: image87.png]



20. Hiệu chỉnh Sketch 

Kích chuột phải lện đặc điểm Extrude1 trên cây FMD và chọn Edit Sketch. Khi đó ta có thể thay đổi, xoá hoặc thêm các đổi tượng mới vào Sketch.

[image: image88.png]


Ví dụ ta thay đổi lại bán kính góc lượn: 10mm bằng cách nhắp đúp chuột vào kích thước cần hiệu chỉnh.
Giới thiệu công cụ Circle (tạo đường tròn)

Công cụ Circle được sử dụng để tạo sketch đường tròn cho các việc tạo các đặc điểm cut hoặc boss. Nó được xác định bởi 2 vị trí: Tâm của đường tròn và điểm thứ 2 để xác định bán kính đường tròn.

Để kích hoạt công cụ tạo đường tròn ta có thể thực hiện theo những cách sau:

Chọn menu Tools > Sketch Entity > Circle.

Hoặc kích Circle [image: image16.png]


  trên thanh công cụ Sketch Tools.
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20. Tạo đường tròn

Kích Circle [image: image17.png]


 trên thanh công cụ Sketch Tools và tạo đường tròn có tâm trùng với tâm của góc lượn (hình 2.23)

21. Ghi kích thước cho đường tròn vừa tạo

Sử dụng công cụ Dimension, chọn biên của đường tròn và xác định vị trí ghi kích thước bên ngoài đường tròn. Nhập đường kính = 10mm và kích OK. 


22. Thoát khỏi chế độ hiệu chỉnh Sketch

Có nhiều cách khác nhau để thoát khỏi chế độ hiệu chỉnh.

Kích Rebuild [image: image18.png]


 trên thanh công cụ Standard.

Kích chuột phải trên màn hình đồ hoạ và chọn Exit Sketch từ menu ngữ cảnh.

Kích vào biểu tượng Exit Sketch ở phía góc trên bên phải của vùng đồ hoạ (hình 2.25).
Mô hình sau khi đã hiệu chỉnh.
23. Kích Save để lưu lại bản vẽ

Ví dụ
Ví dụ 1:

Tạo chi tiết hình 2.27

Trước tiên ta tạo biên dạng của chi tiết (bao gồm cả đưòng tròn)

Ghi kích thước cho các đối tượng trong Sketch

Sử dụng công cụ Extrude tác động lên Sketch để tạo đặc điểm Solid.

Biên dạng của đặc điểm Extrude (hình 2.28)
1. Mở bản vẽ mới

Tạo bản vẽ Part với đơn vị đo là mm

2. Tự động tạo các mối quan hệ

Sử dụng  công cụ Line và chế độ tự động tạo các mối quan hệ. Chú ý các biểu tượng chỉ mối quan hệ vuông góc và theo phương đứng.



3. Ghi kích thước

Ghi kích thước cho các đối tượng trong Sketch để các đối tượng được định nghĩa đầy đủ.


4. Tạo đường tròn

Tạo đường trong và ghi kích thước cho nó như trên hình 2.31.

5. Extrude

Extrude Sketch với chiều sâu Extrude là 10 mm

6. Kích Save để lưu lại bản vẽ

Ví dụ 2: Tạo chi tiết như hình 2.33
Các bước tiến hành

Tạo Sketch

Ghi kích thước

Extrude để tạo đặc điểm

Hiệu chỉnh Sketch

1. Mở một bản vẽ mới chọn đơn vị đo là mm
2. Trên mặt phẳng vẽ phác tạo biên dạng của mô hình với các ràng buộc tự động được thiết lập (hình  2.30).
3. Sử dụng công cụ Extrude để tạo mô hình từ biên dạng đã có trên mặt phẳng vẽ phác (hình 2.30) .

4. Trên cây FeatureManager Design Tree nhấn chuột phải vào mặt phẳng vẽ phác Sketch1 và chọn Edit Sketch từ menu ngữ cảnh.

5. Tạo đường tròn trên mặt phăng vẽ phác và ghi các kích thước cho đối tượng (hình 2.32).
6. Kích Rebuid trên thanh công cụ để xây dựng lại bản vẽ.

7. Lưu lại bản vẽ.
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